A flaw has been found in agentscope-ai AgentScope up to 2.0.8.
A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.
Read at NIST National Vulnerability Database (CVE API 2.0)
- Vendor
- Agentscope-Ai
- Product
- AgentScope
- CVSS v3.1
- 7.3 AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Exploitation
- public exploit code reported
- Weakness
- CWE-285, CWE-863
- NVD status
- Deferred
Why it ranks 37 (Notable)
- Public exploit code reported
- CVSS v3.1 7.3 high
- Recency: items published within 24 hours gain 15, within 72 hours 6, within 7 days 2.
Links
- NIST National Vulnerability Database (CVE API 2.0) (nvd.nist.gov)
- CVE-2026-123023 on this site · NVD · CVE.org · Vulnpedia
Related coverage
Other items that share a CVE or were clustered with this one.