Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web…
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
Read at NIST National Vulnerability Database (CVE API 2.0)
- Vendor
- AWS
- Product
- maplibre-gl-js-amplify
- CVSS v3.1
- 5.4 AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Fix
- available
- Weakness
- CWE-79
- Exposure class
- Cloud platform
- NVD status
- Received
Why it ranks 28 (Notable)
- CVSS v3.1 5.4 medium
- Product class: cloud platform
- Fix available
- Recency: items published within 24 hours gain 15, within 72 hours 6, within 7 days 2.
Links
- NIST National Vulnerability Database (CVE API 2.0) (nvd.nist.gov)
- CVE-2026-121652 on this site · NVD · CVE.org · Vulnpedia
Related coverage
Other items that share a CVE or were clustered with this one.